XRP Withdrawn in maintenance
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 11:47 CET
Investigating
We are currently investigating the issue of the XRP withdraws
Posted Nov 13, 2022 - 12:31 CET
This incident affected: Cryptocurrencies (XRP).