<cryptocurrency_name> wallet upgrade
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted May 18, 2020 - 15:36 CEST
Investigating
The Bitcoin cash wallet will be upgraded due a mandatory software update. Buying, selling and withdrawing from your LiteBit wallet is currently in maintenance for the listed cryptocurrencies.

If there are any deposits which do not show up as pending it will be added once the maintenance has been resolved.
Posted May 18, 2020 - 14:15 CEST
This incident affected: Cryptocurrencies (Bitcoin Cash).