Maintenance on exchange partners
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted Jan 12, 2021 - 11:01 CET
Update
We are continuing to monitor for any further issues.
Posted Jan 12, 2021 - 11:01 CET
Update
Maintenance on Stellar (XLM)

Stellar (XLM) is currently not available for buying and selling, . On the platforms of our exchange partners that we as a broker use
Posted Jan 06, 2021 - 16:25 CET
Update
We are continuing to monitor for any further issues.
Posted Jan 06, 2021 - 09:23 CET
Monitoring
Due to maintenance on exchange partners we are currently not able to buy and sell the listed cryptocurrencies.
Posted Jan 06, 2021 - 09:06 CET
This incident affected: Cryptocurrencies (Stellar).