XLM withdraws maintenance
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 10:29 CET
Investigating
We are currently investigating the issue with the XLM withdraws
Posted Nov 24, 2022 - 14:47 CET
This incident affected: Cryptocurrencies (Stellar).