EUR deposits delay
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted Sep 09, 2022 - 11:13 CEST
Identified
The issue has been identified and a fix is being implemented. New deposits are being processed correctly already.
Posted Sep 09, 2022 - 11:03 CEST
Investigating
EUR deposits are currently not added to the account instantly. Deposits will be added automatically once the issue is resolved
Posted Sep 09, 2022 - 10:37 CEST
This incident affected: Payment Methods (iDeal, SEPA bankwire, LiteBit credits, SOFORT, GiroPay, Bancontact, Credit Card, EPS uberweisung).