Terra (LUNA) maintenance
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted May 30, 2022 - 15:59 CEST
Investigating
We are currently investigating this issue.
Posted May 26, 2022 - 16:10 CEST
This incident affected: Cryptocurrencies (Terra).