Email Delivery Issues
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted Sep 12, 2022 - 21:39 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2022 - 21:15 CEST
Identified
We experienced issues with our mail services, and as a result some of our customers did not receive their password codes.
Posted Sep 12, 2022 - 20:38 CEST
This incident affected: Email delivery.