Withdrawn in maintenance
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 11:47 CET
Investigating
We are currently investigating the withdrawal issue
Posted Nov 13, 2022 - 22:47 CET
This incident affected: Cryptocurrencies (Cardano, TRON).