Delay in transactional emails detected
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted Jan 05, 2021 - 09:26 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 04, 2021 - 17:30 CET
This incident affected: LiteBit - Email delivery.