Maintenance on exchange partners
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted Mar 13, 2020 - 10:10 CET
Monitoring
Due to maintenance on exchange partners we are currently not able to buy and sell the listed cryptocurrencies.
Posted Mar 12, 2020 - 18:41 CET
This incident affected: Cryptocurrencies (Status).