Website and App incident
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted Aug 11, 2022 - 14:50 CEST
Investigating
We are aware of the current issue with the website and app. We are looking into this right now and will report when more information is known. Scroll down to find the current status.
Posted Aug 11, 2022 - 13:09 CEST