LiteBit user wallets deposits delayed for Cardano (ADA)
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 16:25 CEST
Investigating
We are currently experiencing some delay with ADA deposits. The LiteBit team is working hard to solve this as soon as possible. Apologies for the inconvenience
Posted Jun 04, 2021 - 16:19 CEST
This incident affected: Cryptocurrencies (Cardano).