Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 16, 2020 - 10:05 CET
Scheduled
Due to a mandatory upgrade, we will not be able to trade Cardano until the maintenance has been resolved. Buying, selling and withdrawing will be unavailable. Deposits will show up in the user wallets after the maintenance has been resolved
Posted Dec 16, 2020 - 10:04 CET
This scheduled maintenance affected: Cryptocurrencies (Cardano).