LUNA blockchain halted
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted May 13, 2022 - 16:42 CEST
Update
We are continuing to work on a fix for this issue.
Posted May 13, 2022 - 12:16 CEST
Identified
The Terra Blockchain was halted. Due to limited liquidity, extreme volatility and blockchain issues and buy orders of LUNA and ANC have been suspended.

Selling ANC is still available.
Posted May 13, 2022 - 09:21 CEST
This incident affected: Cryptocurrencies (LUNA, ANC).