Ethereum withdrawals disabled
Incident Report for LiteBit Services
Resolved
We have resumed the withdrawals of Ethereum. Gas prices have stabilized. Please be aware of withdrawal costs which may change.
Posted Feb 24, 2021 - 14:11 CET
Identified
Due to congestion on the Ethereum network and a steep increase in transaction costs, we have temporarily disabled Ethereum and ERC20 withdrawals. When Gas prices stabilize we will re-enable withdrawals.
Posted Feb 22, 2021 - 16:00 CET
This incident affected: Cryptocurrencies (Ethereum).