Ethereum ERC-20 withdrawals
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 10:00 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2020 - 09:44 CET
Identified
The issue has been identified and a fix is being implemented
Posted Feb 13, 2020 - 09:41 CET
Investigating
We noticed a delay in ERC-20 withdrawals.

We are currently investigating this issue.
Posted Feb 13, 2020 - 09:35 CET
This incident affected: Cryptocurrencies (Ethereum).