Temporary email delivery issues Mijndomein.nl
Incident Report for LiteBit Services
Resolved
This incident has been resolved.
Posted Feb 06, 2020 - 09:26 CET
Update
We received positive feedback from our customers that we could deliver emails recently.

We are continuing to monitor for any further issues.
Posted Feb 06, 2020 - 09:18 CET
Monitoring
Mijndomein.nl is resolving the issue, we will monitor the email delivery
Posted Feb 05, 2020 - 11:48 CET
Identified
The issue has been identified and discussed with Mijndomein.nl
Posted Feb 04, 2020 - 13:58 CET
Update
We are continuing to investigate this issue.
Posted Feb 04, 2020 - 10:42 CET
Investigating
We received complaints from our customers about email delivery failures at Mijndomein.nl user mailboxes.

We shared technical information with the Technical team of Mijndomein.nl.
Posted Feb 04, 2020 - 10:41 CET
This incident affected: LiteBit - Email delivery.